Enterprise Architect ENTERPRISE ARCHITECT

系统需求


Windows

- Microsoft® Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Vista, Windows Server 2012 R2 或 Windows 2008 Server.
(支持32位和64位操作系统 *)
- 2GB的RAM
- 800MB可用硬盘空间
- 1280 * 720或更高分辨率的显示屏

 

Linux

- Linux操作系统(内核2.4或更高版本)
- Wine ** 1.8 (最低), 1.9x或更高版本(推荐)(或等效的CrossOver版本)
- Microsoft数据访问组件(MDAC)2.8
- 2GB的RAM
- 800MB可用硬盘空间
- 1280 * 720或更高分辨率的显示屏

 

Mac OS X

- Mac OS 10.8或更高版本
- Wine 1.8 (最低)(或CrossOver Mac 15.0.1或更高版本)
- Microsoft数据访问组件(MDAC)2.8
- 基于Intel® 的处理器
- 2GB的RAM (建议使用128 MB或更高)
- 800MB可用硬盘空间
- 1280 * 720或更高分辨率的显示屏

 

 

支持的数据库产品(DBMS),用作Enterprise Architect模型存储库***

- Firebird
- MariaDB
- MySQL
- MS SQL Server (包括Express和Azure)
- MS Access
- Oracle
- PostgreSQL

 

Windows Vista和Windows 7用户请注意:
在Windows Vista下(启用了用户帐户控制),应用程序仅以标准权限启动,无论当前用户具有什么级别的权限。 因此,安装程序正常运行Vista下的管理员帐户只具有标准权限,可能无法写入某些关键注册表/文件系统的区域,或将写入请求重定向到每用户虚拟化注册表/文件系统。

Sparx Systems建议,如果要在Windows Vista上进行安装,请使用管理员权限(建议您启用了UAC)安装Enterprise Architect程序。应用程序获得管理员权限,需要右键单击下载的安装程序图标,然后选择菜单选项“以管理员身份运行”。

* Enterprise Architect是一个32位应用程序,但它可以在32位和64位Windows操作系统上运行。

** Wine 不断更新。 为获得最佳体验,我们建议您保持更新winehq.org的稳定版或开发版的新版本 。 开发版本经常使用修复程序进行更新, 这将直接提高Enterprise Architect的兼容性,但有时可能会遇到小问题。 总的来说,我们相信这个分支可以为Enterprise Architect提供最佳体验。

*** 基于文件的数据库, MS Jet和Firebird可以与任何版本的Enterprise Architect一起使用。 这些存储库文件分别命名为* .eap和* .feap。 但是,在基于服务器的DBMS存储库中托管模型需要企业版或更高版本。 有关受支持的DBMS版本的列表,DBMS产品下的帮助主题。请参阅在可以使用的DBMS标题下基于服务器的存储库